INVERT options=double problem for 64-bit source MIRIAD

Is MIRIAD being a pain? Let us know your experience.

Moderator: Mark.Wieringa

INVERT options=double problem for 64-bit source MIRIAD

Postby cAh » Wed May 12, 2010 11:56 am

Hi ATCA nerds,

I sent the following email to Mark Calabretta on 11 May 2010.

I have installed linux64 MIRIAD from source, and have modified MAXDIM to 32767 (I also increased MAXBUF to 64*1024*1024, though I don't think it's really necessary).

My problem is that when I try to run invert on a single channel (or even multi-frequency) uv-dataset with options=double (or options=double,mfs) and with an imsize larger than exactly 8192 (which is the maximum 32-bit allowable value), then my beamsize is limited to the imsize that I have entered: ie it doesn't make it twice as large as the image. Given that I increased MAXDIM, it should.

For example:

If I choose imsize=8192 then I correctly get a beamsize of around 16384x16384.

If I choose imsize=8193 then I incorrectly get a beamsize of 8193x8193 (it should be around 16390x16390, which is still smaller than 32767x32767).

If I choose imsize=16000 then I get an image around 16000x16000 and a beam of around 16000x16000.

And if I choose imsize=17000 then INVERT doesn't want to run, telling me that the "Maximum permitted image size is 32767" (which is a line in $MIR/prog/invert.for). If the previous case is anything to go by, then I should get a beam of size 17000x17000. But in a correct way, MIRIAD picks up that I have used options=double and prevents a beam from being generated of size twice 17000 (which is greater than 32767).


In an effort to get around this problem, I thought I could perhaps turn off the "double" option (ie don't use it), and set imsize=18000, for example, so that I would get a beam of 18000x18000. In this way I could then recreate an image of size 9000x9000 and have full coverage of my image with the beam for cleaning (with CLEAN).

Unfortunately, MIRIAD doesn't like this and again complains that "### Fatal Error: Maximum permitted image size is 32767". This is weird, because I am not trying to make an image larger than 32767; indeed, I am only trying to make an image of size 18000.


If anyone has come across either of these two problem before (ie options=double not working properly for imsize greater than 8192; or invert not working for imsize greater than 16384 in a 64bit install when options=double is _not_ used) and knows how to fix them, then I am very interested to hear from you. I am hoping that, in the simplest case, I have missed modifying a parameter somewhere before building my 64-bit MIRIAD.


Chris Hales
c.hales@physics.usyd.edu.au
cAh
 
Posts: 5
Joined: Tue May 04, 2010 12:57 pm

Return to MIRIAD

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron