Infinite beam

Got an image problem? Let us help!

Moderator: Mark.Wieringa

Infinite beam

Postby mar » Wed Jun 05, 2013 9:19 pm

I am reducing some archival ATCA data at 32GHz, array in
config. EW352, source at DEC -30deg, and I have encountered a problem
which I do not know how to solve: though the data reduction looks goods,
when making an image of my .imodel with the task restor I get
''Using Gaussian beam fwhm of NaN by 0.124 arcsec''
so the beam goes to infinite. Any idea of what could be wrong?

I have tried imaging excluding antenna 6, but I still get the same error.

Posts: 2
Joined: Wed Jun 05, 2013 8:36 pm

Re: Infinite beam

Postby ste616 » Wed Jun 05, 2013 10:53 pm

Hi Mar,

I have also gotten this error on occasion. It usually occurs when the beam is quite elongated, or undersampled in a particular direction.

Thankfully there is an easy enough solution, although it is a bit more complicated than simply using restor. After either the invert or clean steps, you can use the imfit task to measure the beam, using object=beam. You will probably need to select a small central region before this will work, but then you will get something like the following:

Source 1, Object type: beam
Major axis (arcsec): 1.286 +/- 0.001
Minor axis (arcsec): 1.198 +/- 0.001
Position angle (degrees): 2.45 +/- 0.44

You can now take these parameters and input them to restor. From this example you would set fwhm=1.286,1.198 and pa=2.45. This should then give you a good restored image.
Jamie Stevens
ATCA Senior System Scientist
Site Admin
Posts: 217
Joined: Thu Feb 04, 2010 3:27 pm
Location: Paul Wild Observatory Narrabri NSW

Re: Infinite beam

Postby mar » Thu Jun 06, 2013 8:50 pm

Thanks!! It worked!!
Posts: 2
Joined: Wed Jun 05, 2013 8:36 pm

Return to Imaging

Who is online

Users browsing this forum: No registered users and 1 guest