Page 1 of 1

invert in MIRIAD and cellsize

PostPosted: Tue Aug 13, 2013 2:52 pm
by minh25

I've making I, Q and U cubes of CABB 5.5 GHz data, across the full 2 GHz band, so that we can investigate RM synthesis techniques in measuring the rotation measure of some sources.

I run invert with the folllowing (e.g. for U):

vis = ecdfs_fullband_6.5500.uv
map = ecdf_fullband_line10chan_6.umap
beam = ecdf_fullband_line10chan_6.ubeam
imsize = 1300
cell = 0.5
robust = 1
line = channel,200,5,10,10
stokes = u
options = systemp
slop = 1

The source of interest lies a little off the pointing centre (this is one of the mosaic pointings from my 42 pointing mosaic of eCDFS). For each plane or channel it has a different x,y position because the default of MIRIAD is to scale the cell size! As noted in the online MIRIAD manual this is okay when the fractional bandwidth is small, but we're talking about CABB at 5.5 GHz.

To run a RM synthesis code I need the source, or coordinates, in each x, y pixel to be the same in each plane or channel. That is, I need to have the cell size not scaled. Can you make an update to invert that allows one to turn off this cell size scaling?

Hopefully this is a simple hack and you can have a new version of invert available quickly?


Re: invert in MIRIAD and cellsize

PostPosted: Tue Aug 13, 2013 3:05 pm
by Mark.Wieringa
Hi Minh,

unfortunately I don't think this is easily fixed. The problem is the beam - if you don't scale the image, you need a separate beam for each plane, and miriad has never been able to produce this. It uses higher dimensional beams for mosaicing and mfs, adding a spectral dimension is complicated.

I think your options are to make the image planes one by one and then imcat them together, or to use CASA.



Re: invert in MIRIAD and cellsize

PostPosted: Tue Aug 13, 2013 4:40 pm
by Mark.Wieringa
Hi Minh,

actually, it is not as bad as I said earlier:

I just found that the task regrid has an option noscale, so you can just run invert as normal and then do
regrid in=scaled.cube out=unscaled.cube options=noscale
to get an image cube with unscaled coordinates.

You'll need to clean this cube before doing the scaling.
Of course the beam size will still scale with frequency.