Importing ATCA obs into CASA (ms file)

Want to use CASA with CABB data? We can help each other!

Moderator: Mark.Wieringa

Importing ATCA obs into CASA (ms file)

Postby bnorfolk » Thu Feb 04, 2021 10:29 am

Hi all,

I'm having some major issues converting an ATCA obs into a CASA measurement set. Currently I've tried to export the data with fits and then re-import it in CASA with importuvfits. I then tried to just import the ATCA obs folder with importmiriad. importatca just produces corrupt data errors. I'm on CASA 5.3. Both importuvfits and importmiriad initally work but when I bin the real and imaginary components of the visibilities there's a significant difference to that produced by uvdump in miriad. Any suggestions?

Screen Shot 2021-02-04 at 10.29.11 am.png
Screen Shot 2021-02-04 at 10.29.11 am.png (209.85 KiB) Viewed 3450 times
Posts: 45
Joined: Fri May 17, 2019 3:56 pm

Re: Importing ATCA obs into CASA (ms file)

Postby Mark.Wieringa » Thu Feb 04, 2021 3:32 pm

Hi Brodie,

All these options used to work ok, although I've never made the kind of plot you have.
Some possible causes of difference are
* calibration: you need to apply this to the data before exporting to fits or importing with importmiriad;
* weighting - default weights are integration time, you may want tsys weighting

I'm surprised by the corrupt data errors - did you feed importatca RPFITS files? What was the error message?
The same RPFITS code is used to read the files in Miriad and CASA so they 'should' behave similarly.


ATCA Expert
Posts: 293
Joined: Mon Feb 08, 2010 1:37 pm

Return to CASA

Who is online

Users browsing this forum: No registered users and 1 guest