maxen running slowly

Is MIRIAD being a pain? Let us know your experience.

Moderator: Mark.Wieringa

maxen running slowly

Postby ycendes » Tue Mar 07, 2017 9:42 am

Hi,

As requested, I am posting to confirm that I'm having issues running maxen at a fast speed- one iteration takes at least a second. (mfcal runs great though, thanks!)

Details:

Command I am using: "maxen map=sn1987a.1.imap beam=sn1987a.1.beam out=sn1987a.1.icmp niters=200 rms=1e-7 region=@first.region"

As for the files I'm runing, they are available in the dropbox folder here.

Thanks again!
ycendes
 
Posts: 4
Joined: Wed Jan 11, 2017 8:15 am

Re: maxen running slowly

Postby Mark.Wieringa » Tue Mar 07, 2017 1:33 pm

Hi,

Two things:
- a maxen iteration is not like a clean iteration, you'll only need 20-100 maxen iterations to deconvolve an image, whereas you might need several 1000's of clean iterations.

- I think maxen is not being very smart with the very large beam you're giving it. If you decrease the beam size to 2048 pixels or less it runs much faster (imsub in=beam out=beam.small "region=perc(20)"). Since your region is pretty small, you get the same results. The beam really only needs to be twice the size of the region to deconvolve. The region probably needs to be a bit larger than 'first.region' to avoid the edge effects.

Cheers,

Mark
Mark.Wieringa
ATCA Expert
 
Posts: 284
Joined: Mon Feb 08, 2010 1:37 pm

Re: maxen running slowly

Postby ycendes » Thu Mar 09, 2017 10:07 am

Ah ok- mea culpa, I didn't specify the image size correctly in the earlier invert command. Makes all the difference, maxen runs much faster now.

Thanks for the help and for the other tips! :)
ycendes
 
Posts: 4
Joined: Wed Jan 11, 2017 8:15 am


Return to MIRIAD

Who is online

Users browsing this forum: No registered users and 1 guest

cron