Page 1 of 1

mf cal fail on OSX Catalina

PostPosted: Wed Nov 25, 2020 11:32 pm
by jcal
Hi all,

I recently upgraded to Catalina (10.15.7). I installed miriad without any issues up until now. Uvspec, pgflag etc seem to be working, but when I call mfcal, it breaks with what could be C memory issue?

Suggest any solutions to this problem? Have I stuffed up the install?



Current working directory: /Users/jcal/postdoc/projects/wr112_atca
Current host: Mimir.local
Last system update:
System details: Darwin Mimir.local 19.6.0 Darwin Kernel Version 19.6.0: Mon Aug 31 22:12:52 PDT 2020; root:xnu-6153.141.2~1/RELEASE_X86_64 x86_64

vis = 1934-638.test
line =
stokes =
edge =
select =
flux =
refant =
minants =
interval =
options =
tol =


Output from mfcal:
MfCal: $Revision: 1.20 $, $Date: 2017/05/08 02:31:10 $
Selecting parallel-hand polarisations
### Fatal Error: Memory allocation problem in memAlloc

Re: mf cal fail on OSX Catalina

PostPosted: Wed Jun 02, 2021 4:49 pm
by Mark.Wieringa
Hi Joe,

sorry for the late reply, somehow I didn't get notified.
I've just installed a new version of miriad that fixes the problem (at least for me).



Re: mf cal fail on OSX Catalina

PostPosted: Sat Jul 31, 2021 3:20 am
by vamoss
Just noting: the new miriad worked for me, I ran "mirsync" to get the latest version and the memory allocation error disappeared :) thanks Mark!

Re: mf cal fail on OSX Catalina

PostPosted: Mon Aug 02, 2021 10:33 am
by Mark.Wieringa
No worries, I finally bit the bullet and managed to get rid of the offending code altogether.