unexpected mosaicing behaviour

Got an image problem? Let us help!

Moderator: Mark.Wieringa

unexpected mosaicing behaviour

Postby berapnopod » Tue Oct 15, 2013 1:27 pm

I am not quite sure how to describe the problem, but here goes...

We took some L-band data for C2290 last year in two configurations:
In May we did EW352 and then in July we did 750A. The observations consisted of mosaicing 24 pointings. The setup for each run was identical, just the array was different.

We've processed the July 750A data and it all looks very good. But we are having problems with the May EW352 data. The first 9 pointings in the mosaic look fine and combine well with the other data. However, the rest of the pointings look like a mess with emission where we don't expect to see it. In fact, you can look at images of the pointings separately and see that in overlap areas the emission does not match up. It is like the telescope was pointing at the wrong place.

But I have checked the mosaic file used in SCHED with the header information in the individual pointings and they agree well. So I would guess the telescope was pointing in the right direction for each position. But we have no idea why the emission we see in these data does not match what we expect. Furthermore, it appears that we can manually apply offsets to the individual pointings and get a reasonably good match of the emission. That suggests the mosaic positions were wrong. But, as I said, the mosaic file checks out with the headers.

I realise this is probably not enough information to diagnose a problem, but I am hoping to at least get the ball rolling with this post.

Later. Andrew xxx
berapnopod
 
Posts: 3
Joined: Mon Jul 02, 2012 5:16 pm

Re: unexpected mosaicing behaviour

Postby Mark.Wieringa » Tue Oct 15, 2013 3:27 pm

Hi Andrew,

it sounds you may have run into the infamous mosaic field name length bug that was fixed around the 22nd of May 2012. Until that time CABB would only read the first 8 characters of the mosaic field name when setting the phase centre position. This means that in your case field number 10 to 19 may be using the phase centre of field 1. You can confirm this by making an image of both fields – the strong sources will appear in exactly the same pixel position in the image, even though the coordinates attached to the image are different. Note that the antennas were pointing in the correct position, so you have not lost any sensitivity, it is just the phase centre and axis labelling which are wrong.

Laura Richter (South African SKA project) and Tim Shimwell (Cen A project) both ran into this problem with their mosaic data and found the best way to recover the data is to first image all the fields individually, then fix the headers (with puthd) to put in the actual phase centre position (in your case this probably means the 1st position for field 10-19 and the 2nd position for field 20-24). After all images have the correct header you can run linmos to combine the images and all should be well since invert stores the pointing position in a separate mosaic table in each image.

The only residual effects should be time and bandwidth smearing, which would be based on the actual phase centre positions used. If your fields are a long way away from this, you may notice point sources becoming somewhat extended.

If you are attempting joint deconvolution, or want to combine uv data for different epochs during imaging you can try using uvputhd to set the correct ra/dec phase centre for each field and then use uvedit to shift the data to the intended phase centre. Laura reported small residual position offsets with this method though - depending on your image resolution this may affect you.

Cheers,

Mark
Mark.Wieringa
ATCA Expert
 
Posts: 257
Joined: Mon Feb 08, 2010 1:37 pm

Re: unexpected mosaicing behaviour

Postby berapnopod » Tue Oct 15, 2013 3:49 pm

Oh wow!
Thanks for the quick and concise response, Mark!
I was expecting a long drawn out diagnosis :)

Later. Andrew xxx
berapnopod
 
Posts: 3
Joined: Mon Jul 02, 2012 5:16 pm


Return to Imaging

Who is online

Users browsing this forum: No registered users and 1 guest

cron